Added updated testing cards for all supported countries
Added Austrian fiscalization info in FiscalInfo datastructure
Added German fiscalization info in FiscalInfo datastructure
Added info about BillSubItem in BillItem
Added info about lock timeout on paymentStart
Added info about mandatory state checking on paymentClosed
Added the “Loyalty cards” extension
Removed the “Call the waiter” extension
Removed the pairCustomer() method
Cleared up production Pos-Id assignment process
Added a section about Qerko functions and use cases
Fixed a mistake in the Discount structure - the description property should be called name
Added BKP in Slovakia FiscalInfo
Added receiptDeliveryType POSTPONED
Added the Slovakia-specific parameters to FiscalInfo
Added the ReceiptDeliveryType parameter of the Receipt structure
Fixed dead links
Added the Orders extension doc link
Improved documentation of Table
Replaced testing credit card due to payment gateway switch
Improved documentation of Websocket close codes
Fixed some grammar mistakes and typos
Updated test credit card
Changed the magic keyword for switch to development environment to qerko-toggle-test
Added headerLines, headerText, footerLines, footerText to FiscalInfo structure
Added optional Extensions
Corrected a few typos
Corrected a few mistakes in examples
Added payment diagram
Added optional MethodCallResponse.calledMethod
Added missing info about time limit of method cancelPayment(...)
Added error codes: ACCESS_DENIED, ALREADY_AUTHORIZED, NO_SUCH_METHOD, NOT_FOUND, TIME_LIMIT_EXPIRED
Changed Error.reason to Error.code
Added list of Error Codes
BillItem.tags are no longer required
BillItem.minQuantity default value is 1
Renamed BillDiscountOffer.description to BillDiscountOffer.name
Renamed Payment.tip to Payment.tipBrutto
Renamed Payment.idUser to Payment.idCustomer
Added Payment.state STARTED
Added Receipt.receiptInfo and structure ReceiptInfo
Moved Receipt.footerLines to changes in ReceiptInfo.footerLines
Moved Receipt.headerLines to changes in ReceiptInfo.headerLines
Moved Receipt.waiter in ReceiptInfo.waiter
Receipt.items are required now
Added Receipt.fiscalInfo and structure FiscalInfo
Renamed BillItem.amount to BillItem.quantity Added optional property Receipt.items Minor changes in descriptions
Added locale into Authorization request message
Payment.paymentProvider was replaced by Payment.parts Added PaymentPart structure Added BillItem.amount Added BillItem.id Added BillItem.splittable Changed BillItem.price
Added headerLines a footerLines to the Receipt structure Removed lines form the Receipt structure
Allow to skip nullable properties in data structures Renamed pairUser(...) to pairCustomer(...)
Added Bill.denyDiscounts This can prevent Qerko from applying a discount
18. 4. 2019
It Is Paid is renamed to Qerko
This document is in English now
Introducing API v2.
Added websocket support.
Added Bill structure.
This brings support for multiple bills on a table.
Added BillDiscountOffer structure.
This brings support for POS discount offers.
Added BillItem structure.
This brings support for additionalData that can be used by POS.
This brings the all new tags set for item categorization or recognition.
Added Discount structure.
Successor of the Sale structure.
Support for various discount sources.
Added endpoint for cancelling the payment.
For the ability to cancel the payment in case of a customer issue.
Added getBill(...) method.
For the ability to get the contents of an exact bill.
Added pairUser(...) method.
For the ability to pair Qerko’s users and POS loyalty DB.
Added TaxInfo structure.
Taxes are completely calculated by POS now.
Added Receipt structure.
Successor of BillInfo.
Many changes due international differences.
Just for convenience. This has introduced no functional changes.
Type of MethodCallResponse.error has changed.
Changed method error(...).
Error is be reported using Error structure, not just string.
Changed method getTableContents(...).
Added idUser argument, so POS can offer discounts.
Changed methods paymentProcessed(...) and paymentClosed(...).
To prevent sending the same data more than once and the validation related with it.
Replaced by Payment.idBill.
It was confusing and useless.
It was useless.
Removed BillInfo structure.
Replaced by Receipt.
Removed Sale structure.
Replaced by Discount.
Removed TableContents structure.
Replaced by Bill.
Removed TableItem structure.
Replaced by BillItem.